Android SDK Android SDK v2.0
最終更新日 2015-6-22

はじめに

Appiaries Android SDK 2.0.0 開発者ガイド

このドキュメントについて

想定する読者について

本ドキュメントは、アピアリーズをバックエンドサーバとして使用する、Androidアプリ開発者向けの内容となっています。

SDKの利用にあたっての前提条件

以下に、Appiaries Android SDK(以降、Android SDK、または単に SDK と表記)を利用するにあたっての前提条件を示します。

  • アピアリーズのアカウントを作成済みであること
  • Androidアプリ開発について基本的な知識/理解を有すること
  • JSONフォーマットについて基本的な知識/理解を有すること
  • RESTアーキテクチャスタイルについて基本的な知識/理解を有すること

SDK がサポートする Android OS バージョン一覧

Android OS バージョン
4.0 (Ice Cream Sandwich)
4.1 (Jelly Bean)
4.2 (Jelly Bean)
4.3 (Jelly Bean)
4.4 (KitKat)
5.0 (Lollipop)
5.1 (Lollipop)

SDKの利用にあたっての注意事項

依存ライブラリ/フレームワーク

SDK の利用には、以下に挙げるライブラリが必要となります。

ライブラリ名 バージョン 配布先リンク
httpclient-android.jar 4.3.5.1 » 外部サイト MVN REPOSITORY のダウンロードページへ移動します
httpcore.jar 4.3.2 » 外部サイト Apache Software Foundation のダウンロードページへ移動します
httpmime.jar 4.3.4 » 外部サイト MVN REPOSITORY のダウンロードページへ移動します
jackson-core-asl.jar 1.8.3 » 外部サイト MVN REPOSITORY のダウンロードページへ移動します
jackson-mapper-asl.jar 1.8.3 » 外部サイト MVN REPOSITORY のダウンロードページへ移動します

Facebookとの連携を行う場合は、別途、以下に挙げるライブラリが必要となります。

ライブラリ名 バージョン 配布先リンク
Facebook SDK 3.20.0 » 外部サイト Facebook SDK ダウンロードページへ移動します

Twitterとの連携を行う場合は、別途、以下に挙げるライブラリが必要となります。

ライブラリ名 バージョン 配布先リンク
Twitter4J 4.0.2 » 外部サイト GitHub のダウンロードページへ移動します
oauth-signpost 1.2.1.2 » 外部サイト Google Code のダウンロードページへ移動します

関連情報